Blog

Zen Cart 1.5.0 Official Release

Upgrade Zen Cart to version 1.5.0

Upgrade Zen Cart to version 1.5.0

The new Zen Cart upgrade has been in process for a long time and we are happy to say it is finally here. The beta version was released in July, 2011 for testing. After working out the bugs, Zen Cart 1.5.0 was officially released on December 31st and it is ready for use on a live store.

The upgrade included major system changes to support Zen Cart’s PA-DSS (Payment Application Data Security Standards) compliance certification. This certification is important for PCI compliance for ecommerce stores that accept credit cards online as well as for other security features.

Some of these new PA-DSS features include:

  • Admin passwords now expire every 90 days, as per PA-DSS specification
  • Admin passwords now require a combination of letters and numbers, as well as uniqueness (cannot use already-used passwords)
  • Admin passwords can have a configurable length, but no less than 7 characters
  • Admin passwords also expire, for security reasons, when changing admin configuration from non-SSL mode to SSL mode.
  • Admin Profiles – is now built-in, with a significant number of additional features, and simpler to use.
  • Add basic admin Activity Log Viewer/Exporter tool

Click here for a complete list of v1.5.0 upgrades.

If you run your business via an online Zen Cart store, you will likely need to upgrade to this new version to ensure your site is secure and functioning at maximum efficiency. For the Zen Cart upgrade to work properly, the software must be reinstalled, the database must be upgraded and the template design files must be updated to the new version.

If your store contains any customizations or modules, they must be compatible with v1.5.0 upon upgrade. Your current modules will not function once the newest version is installed. The changes are too extensive with this version to support existing modules.

Zen Cart upgrades are often tedious and difficult even for the expert user. To make this upgrade as easy as possible for Zen Cart store owners, Numinix is offering a simple, low cost, all-inclusive upgrade package. Our service includes an update of your files and database to the new version as well as the re-installation of the new modules that are compatible with v1.5.0. Our professional programmers know which modules are compatible with the upgraded version and understand how to navigate through the process without damaging your existing store. All of your modules will work seamlessly with the new version.

All of our premium modules are v.1.5.0 ready and our free modules are nearing completion as well. If you have any third party Zen Cart modules, they will need to be 1.5.0 compatible. If you own any of our modules, we will upgrade them for free with the purchase of our upgrade package.

New USPS Shipping Module Released

On Jan. 22nd the USPS updated domestic shipping services, product features and the international pricing structure. Zen Cart has released a new module to reflect these changes and replace the existing USPS module.

For $30, Numinix can upgrade your USPS module to the newest version. Click here to find out more about this service.

If you are interested in a complete upgrade to ZenCart’s v1.5.0 including all the modules, find out more information on our Zen Cart Upgrade page.

Leave a Reply

Your email address will not be published. Required fields are marked *

    Get quote Live
    Chat